aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-06-20 00:12:11 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-06-20 00:12:11 +0100
commita119a07983cf24db0bf9715c5625ebb90d915f16 (patch)
tree9a1b4396a189d1522a61cd4447a37a1111832dd8 /default.nix
parent23a380865617a3a47d907c5b71c9757c003b5843 (diff)
add Nix build
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..d915704
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,21 @@
+# SPDX-FileCopyrightText: 2020 Ethel Morgan
+#
+# SPDX-License-Identifier: MIT
+
+{ pkgs ? import <nixpkgs> {} }:
+with pkgs;
+
+buildGoModule rec {
+ name = "catbus-actuator-wakeonlan-${version}";
+ version = "latest";
+ goPackagePath = "go.eth.moe/catbus-actuator-wakeonlan";
+
+ modSha256 = "0nj0ny9692bqcw04fh74g8hqgfh3qc095fsq0y9cy677kp7l2q94";
+
+ src = ./.;
+
+ meta = {
+ homepage = "https://ethulhu.co.uk/catbus";
+ licence = stdenv.lib.licenses.mit;
+ };
+}