summaryrefslogtreecommitdiff
path: root/modules/keyboard.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-18 11:07:29 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-18 11:07:29 +0100
commit0cc815efb58572c9294a271293de815f2c711ed8 (patch)
tree1624bf357e173856e2268eda170adaaef350664c /modules/keyboard.nix
parent0c5741393695fcc99bd79dfc8235d9395204f523 (diff)
import initial NixOS module; also README.md for installation
Diffstat (limited to '')
-rw-r--r--modules/keyboard.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/keyboard.nix b/modules/keyboard.nix
new file mode 100644
index 0000000..69ab14a
--- /dev/null
+++ b/modules/keyboard.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+with lib;
+
+let
+ cfg = config.eth.keyboard;
+
+in {
+
+ options.eth.keyboard = {
+ enable = mkEnableOption "Eth's keyboard preferences";
+ };
+
+ config = mkIf cfg.enable {
+
+ console.useXkbConfig = true;
+
+ services.xserver = {
+ layout = "us";
+ xkbVariant = "colemak";
+ xkbOptions = "caps:escape";
+ };
+
+ };
+}