summaryrefslogtreecommitdiff
path: root/nixos/modules/overlays.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-07-01 15:48:24 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-07-01 15:48:24 +0100
commit36a2b1aeace22517b396d9ff502fa532d173cac0 (patch)
treea46f23d2b8ee2df6d8cfcec75679bfadf16a2d6e /nixos/modules/overlays.nix
parentc85e24ea2b59871ca3b0c2df75cb37163172205a (diff)
move overlays module to a general nix one
Diffstat (limited to '')
-rw-r--r--nixos/modules/overlays.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/nixos/modules/overlays.nix b/nixos/modules/overlays.nix
deleted file mode 100644
index 7820e96..0000000
--- a/nixos/modules/overlays.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
- cfg = config.eth.overlays;
-
- mozilla = import (builtins.fetchTarball
- "https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz");
-
- eth = import ../../pkgs;
-
-in {
- options.eth.overlays = {
- eth = mkEnableOption "Eth (yours truly)";
- mozilla = mkEnableOption "Mozilla (Rust, Firefox, etc)";
- };
-
- config.nixpkgs.overlays = builtins.concatLists [
- ( if cfg.eth then [ eth ] else [] )
- ( if cfg.mozilla then [ mozilla ] else [] )
- ];
-}