summaryrefslogtreecommitdiff
path: root/nixos/modules/programs/dwm.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 22:22:14 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 22:22:14 +0100
commit22b6f7c9feea7aea3d590b8cd217cd3455eb1ad8 (patch)
tree0fcb85274bc9714df730d5c90f8712bce24be04a /nixos/modules/programs/dwm.nix
parent140d29168b9280febcc165c2fbc2778c3ed77494 (diff)
add dmenu to my dwm config
Diffstat (limited to '')
-rw-r--r--nixos/modules/programs/dwm.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/modules/programs/dwm.nix b/nixos/modules/programs/dwm.nix
index c158a5e..5f6b5e0 100644
--- a/nixos/modules/programs/dwm.nix
+++ b/nixos/modules/programs/dwm.nix
@@ -10,7 +10,10 @@ in {
};
config = mkIf cfg.enable {
- environment.systemPackages = [ pkgs.eth.dwm ];
+ environment.systemPackages = with pkgs; [
+ dmenu
+ eth.dwm
+ ];
services.xserver.windowManager.session = singleton {
name = "dwm";
start = ''