summaryrefslogtreecommitdiff
path: root/nixos/modules/sites/recipes.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-07-11 14:11:14 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-07-11 14:11:14 +0100
commit6f589e2bb5ccd25e186317f9f777a74b7fdd6821 (patch)
tree70137a6b6a182ccb31a609ed8294c761741a74b0 /nixos/modules/sites/recipes.nix
parenta280569c89bef9d67e20db601a0a26cc3b0fe302 (diff)
remove eth.sites.* nixos config modules
Diffstat (limited to '')
-rw-r--r--nixos/modules/sites/recipes.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/nixos/modules/sites/recipes.nix b/nixos/modules/sites/recipes.nix
deleted file mode 100644
index 2312e56..0000000
--- a/nixos/modules/sites/recipes.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
- cfg = config.eth.sites.recipes;
-
-in {
- options.eth.sites.recipes = {
- enable = mkEnableOption "Whether to enable recipes.";
-
- https = mkOption {
- type = types.bool;
- default = true;
- description = "Whether to enable HTTPS.";
- };
-
- virtualHost = mkOption {
- type = types.str;
- default = "_";
- description = "Virtual Host to install the site under in Nginx.";
- example = "git.eth.moe";
- };
- };
-
- config = mkIf cfg.enable {
- services.nginx.virtualHosts.${cfg.virtualHost} = {
- forceSSL = cfg.https;
- enableACME = cfg.https;
- root = "${pkgs.eth.recipes}";
- };
- };
-}