summaryrefslogtreecommitdiff
path: root/modules/yubikey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/yubikey.nix')
-rw-r--r--modules/yubikey.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/modules/yubikey.nix b/modules/yubikey.nix
deleted file mode 100644
index 0c16807..0000000
--- a/modules/yubikey.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
- cfg = config.eth.yubikey;
-
-in {
-
- options.eth.yubikey = {
- enable = mkEnableOption "Set up Yubikey";
- };
-
- config = mkIf cfg.enable {
-
- hardware.u2f.enable = true;
-
- programs.ssh.startAgent = false;
-
- programs.gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- pinentryFlavor = "curses";
- };
-
- services.pcscd.enable = true;
-
- services.udev.packages = with pkgs; [
- libu2f-host
- yubikey-personalization
- ];
-
- environment.systemPackages = with pkgs; [
- gnupg
- pinentry-curses
- ];
-
- environment.shellInit = ''
- gpg-connect-agent /bye
- export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)
- '';
- programs.fish.shellInit = ''
- gpg-connect-agent /bye
- set -Ux SSH_AUTH_SOCK (gpgconf --list-dirs agent-ssh-socket)
- '';
-
- };
-}