summaryrefslogtreecommitdiff
path: root/nixos/modules/keyboard.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/keyboard.nix')
-rw-r--r--nixos/modules/keyboard.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/nixos/modules/keyboard.nix b/nixos/modules/keyboard.nix
new file mode 100644
index 0000000..69ab14a
--- /dev/null
+++ b/nixos/modules/keyboard.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+with lib;
+
+let
+ cfg = config.eth.keyboard;
+
+in {
+
+ options.eth.keyboard = {
+ enable = mkEnableOption "Eth's keyboard preferences";
+ };
+
+ config = mkIf cfg.enable {
+
+ console.useXkbConfig = true;
+
+ services.xserver = {
+ layout = "us";
+ xkbVariant = "colemak";
+ xkbOptions = "caps:escape";
+ };
+
+ };
+}