summaryrefslogtreecommitdiff
path: root/nixos/modules/services/catbus-observer-lgtv.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nixos/modules/services/catbus-observer-lgtv.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/nixos/modules/services/catbus-observer-lgtv.nix b/nixos/modules/services/catbus-observer-lgtv.nix
index e1a293c..9e727f3 100644
--- a/nixos/modules/services/catbus-observer-lgtv.nix
+++ b/nixos/modules/services/catbus-observer-lgtv.nix
@@ -8,7 +8,12 @@ let
configJSON = pkgs.writeText "config.json" (builtins.toJSON {
mqttBroker = "tcp://${cfg.mqttBroker.host}:${toString cfg.mqttBroker.port}";
apps = cfg.apps;
- topics = cfg.topics;
+ topics = {
+ app = cfg.topics.input;
+ appValues = cfg.topics.inputValues;
+ power = cfg.topics.power;
+ volume = cfg.topics.volume;
+ };
tv = cfg.tv;
});
@@ -47,12 +52,12 @@ in {
};
topics = {
- app = mkOption {
+ input = mkOption {
type = types.str;
- description = "MQTT topic for controlling the TV's app";
+ description = "MQTT topic for controlling the TV's input";
example = "home/living-room/tv/app_enum";
};
- appValues = mkOption {
+ inputValues = mkOption {
type = types.str;
description = "MQTT topic for exporting the TV's apps";
example = "home/living-room/tv/app_enum/values";