summaryrefslogtreecommitdiff
path: root/nixos/modules/sites/recipes.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nixos/modules/sites/recipes.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/nixos/modules/sites/recipes.nix b/nixos/modules/sites/recipes.nix
deleted file mode 100644
index 2312e56..0000000
--- a/nixos/modules/sites/recipes.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
- cfg = config.eth.sites.recipes;
-
-in {
- options.eth.sites.recipes = {
- enable = mkEnableOption "Whether to enable recipes.";
-
- https = mkOption {
- type = types.bool;
- default = true;
- description = "Whether to enable HTTPS.";
- };
-
- virtualHost = mkOption {
- type = types.str;
- default = "_";
- description = "Virtual Host to install the site under in Nginx.";
- example = "git.eth.moe";
- };
- };
-
- config = mkIf cfg.enable {
- services.nginx.virtualHosts.${cfg.virtualHost} = {
- forceSSL = cfg.https;
- enableACME = cfg.https;
- root = "${pkgs.eth.recipes}";
- };
- };
-}