summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-07-06 18:23:10 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-07-06 18:23:10 +0100
commitb1e6491f77421ae4623391a7f53af7f3e6c13f34 (patch)
treeacc4ce7ae214b92dbf2c269c70e94b68dac1d640 /default.nix
parent04be5845dbaa6f8dec45a80dbe199861608b96f2 (diff)
import website from previous repo
Diffstat (limited to '')
-rw-r--r--default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..cc47ed0
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,31 @@
+{ pkgs ? import <nixpkgs> {} }:
+with pkgs;
+
+stdenv.mkDerivation rec {
+ name = "ethulhu-co-uk-${version}";
+ version = "latest";
+
+ src = ./.;
+
+ buildInputs = [
+ python38
+ python38Packages.jinja2
+ python38Packages.markdown
+ python38Packages.pyaml
+ ];
+
+ patchPhase = ''
+ patchShebangs thrust
+ patchShebangs generate-sitemap
+ '';
+
+ buildPhase = ''
+ make -j
+ '';
+
+ installPhase = ''
+ mkdir -p $out
+ cp -r ./build/* $out
+ '';
+
+}