summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-07-06 18:23:10 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-07-06 18:23:10 +0100
commitb1e6491f77421ae4623391a7f53af7f3e6c13f34 (patch)
treeacc4ce7ae214b92dbf2c269c70e94b68dac1d640 /shell.nix
parent04be5845dbaa6f8dec45a80dbe199861608b96f2 (diff)
import website from previous repo
Diffstat (limited to '')
-rw-r--r--shell.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..960eead
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,23 @@
+# SPDX-FileCopyrightText: 2020 Ethel Morgan
+#
+# SPDX-License-Identifier: MIT
+
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs; mkShell {
+ buildInputs = [
+ aspell
+ aspellDicts.en
+ aspellDicts.en-computers
+ aspellDicts.en-science
+
+ hunspell
+ hunspellDicts.en_US
+
+ entr
+
+ python38Packages.jinja2
+ python38Packages.markdown
+ python38Packages.pyaml
+ ];
+}