summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..960eead
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,23 @@
+# SPDX-FileCopyrightText: 2020 Ethel Morgan
+#
+# SPDX-License-Identifier: MIT
+
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs; mkShell {
+ buildInputs = [
+ aspell
+ aspellDicts.en
+ aspellDicts.en-computers
+ aspellDicts.en-science
+
+ hunspell
+ hunspellDicts.en_US
+
+ entr
+
+ python38Packages.jinja2
+ python38Packages.markdown
+ python38Packages.pyaml
+ ];
+}