summaryrefslogtreecommitdiff
path: root/modules/linode.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
commit433a9ffcbddda74b0449eba251246a60221ae7cd (patch)
tree94792eabcb1e30b1f452ea18fd9c70e267aa4180 /modules/linode.nix
parent1d6f6c4c6f4823d1b969c6309ad2d472441b7b16 (diff)
better mirror upstream nixpkgs layout
Diffstat (limited to 'modules/linode.nix')
-rw-r--r--modules/linode.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/modules/linode.nix b/modules/linode.nix
deleted file mode 100644
index d70c929..0000000
--- a/modules/linode.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ config, pkgs, lib, ... }:
-with lib;
-
-# from https://www.linode.com/docs/tools-reference/custom-kernels-distros/install-nixos-on-linode/.
-
-let
- cfg = config.eth.linode;
-
-in {
-
- options.eth.linode = {
- enable = mkEnableOption "good defaults for Linodes";
- };
-
- config = mkIf cfg.enable {
-
- # Enable LISH serial console.
- boot.kernelParams = [ "console=ttyS0,19200n8" ];
- boot.loader.grub.extraConfig = ''
- serial --speed=19200 --unit=0 --word=8 --parity=no --stop=1;
- terminal_input serial;
- terminal_output serial;
- '';
-
- # GRUB has issues with Linode,
- # so this ignores the warnings.
- boot.loader.grub.forceInstall = true;
-
- # A long timeout to cope with LISH delays.
- boot.loader.timeout = 10;
-
- boot.loader.grub = {
- enable = true;
- version = 2;
- device = "nodev"; # "nodev" for EFI.
- };
- };
-}