summaryrefslogtreecommitdiff
path: root/modules/overlays.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
commit433a9ffcbddda74b0449eba251246a60221ae7cd (patch)
tree94792eabcb1e30b1f452ea18fd9c70e267aa4180 /modules/overlays.nix
parent1d6f6c4c6f4823d1b969c6309ad2d472441b7b16 (diff)
better mirror upstream nixpkgs layout
Diffstat (limited to 'modules/overlays.nix')
-rw-r--r--modules/overlays.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/modules/overlays.nix b/modules/overlays.nix
deleted file mode 100644
index 423275c..0000000
--- a/modules/overlays.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
- cfg = config.eth.overlays;
-
- mozilla = import (builtins.fetchTarball
- "https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz");
-
- eth = import ../pkgs;
-
-in {
- options.eth.overlays = {
- eth = mkEnableOption "Eth (yours truly)";
- mozilla = mkEnableOption "Mozilla (Rust, Firefox, etc)";
- };
-
- config.nixpkgs.overlays = builtins.concatLists [
- ( if cfg.eth then [ eth ] else [] )
- ( if cfg.mozilla then [ mozilla ] else [] )
- ];
-}