summaryrefslogtreecommitdiff
path: root/modules/services/dlnatoad.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
commit433a9ffcbddda74b0449eba251246a60221ae7cd (patch)
tree94792eabcb1e30b1f452ea18fd9c70e267aa4180 /modules/services/dlnatoad.nix
parent1d6f6c4c6f4823d1b969c6309ad2d472441b7b16 (diff)
better mirror upstream nixpkgs layout
Diffstat (limited to 'modules/services/dlnatoad.nix')
-rw-r--r--modules/services/dlnatoad.nix49
1 files changed, 0 insertions, 49 deletions
diff --git a/modules/services/dlnatoad.nix b/modules/services/dlnatoad.nix
deleted file mode 100644
index 8f50c72..0000000
--- a/modules/services/dlnatoad.nix
+++ /dev/null
@@ -1,49 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
- cfg = config.eth.services.dlnatoad;
-
- systemdDirectoryName = "dlnatoad";
- cacheDirectory = "/var/cache/${systemdDirectoryName}";
-
-in {
-
- options.eth.services.dlnatoad = {
- enable = mkEnableOption "Whether to enable DLNAtoad";
-
- directories = mkOption {
- type = types.listOf types.str;
- default = [];
- description = "A list of paths to index & serve.";
- example = [ "/mnt/md0/media" ];
- };
- };
-
-
- config = mkIf cfg.enable {
- systemd.services.dlnatoad = {
- enable = true;
- description = "DLNAtoad UPnP ContentDirectory service";
- wants = [ "network.target" ];
- after = [ "network.target" ];
- wantedBy = [ "multi-user.target" ];
- path = [ pkgs.ffmpeg ];
- serviceConfig = {
- DynamicUser = true;
-
- CacheDirectory = systemdDirectoryName;
-
- ExecStart = "${pkgs.eth.dlnatoad}/bin/dlnatoad ${concatStringsSep " " cfg.directories} --db ${cacheDirectory}/db --thumbs ${cacheDirectory} --verbose";
-
- NoNewPrivileges = true;
- ProtectHome = true;
- ProtectKernelTunables = true;
- ProtectControlGroups = true;
- ProtectKernelModules = true;
- };
- };
- };
-
-}
-