summaryrefslogtreecommitdiff
path: root/nixos/modules/hardware/keyboard.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:59:17 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:59:17 +0100
commit5111fcc4a49bcef1c336e03f5279d053bae3806c (patch)
tree9b4c4fb32baa690238a9d9965e5fc0690c0790d4 /nixos/modules/hardware/keyboard.nix
parent3fa100e7539e25e60d4094d43cb69ae663742556 (diff)
move various hardware configs around
Diffstat (limited to 'nixos/modules/hardware/keyboard.nix')
-rw-r--r--nixos/modules/hardware/keyboard.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/nixos/modules/hardware/keyboard.nix b/nixos/modules/hardware/keyboard.nix
new file mode 100644
index 0000000..69ab14a
--- /dev/null
+++ b/nixos/modules/hardware/keyboard.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+with lib;
+
+let
+ cfg = config.eth.keyboard;
+
+in {
+
+ options.eth.keyboard = {
+ enable = mkEnableOption "Eth's keyboard preferences";
+ };
+
+ config = mkIf cfg.enable {
+
+ console.useXkbConfig = true;
+
+ services.xserver = {
+ layout = "us";
+ xkbVariant = "colemak";
+ xkbOptions = "caps:escape";
+ };
+
+ };
+}