summaryrefslogtreecommitdiff
path: root/nixos/modules/programs/dwm.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
commit433a9ffcbddda74b0449eba251246a60221ae7cd (patch)
tree94792eabcb1e30b1f452ea18fd9c70e267aa4180 /nixos/modules/programs/dwm.nix
parent1d6f6c4c6f4823d1b969c6309ad2d472441b7b16 (diff)
better mirror upstream nixpkgs layout
Diffstat (limited to 'nixos/modules/programs/dwm.nix')
-rw-r--r--nixos/modules/programs/dwm.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nixos/modules/programs/dwm.nix b/nixos/modules/programs/dwm.nix
new file mode 100644
index 0000000..c158a5e
--- /dev/null
+++ b/nixos/modules/programs/dwm.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, ... }:
+with lib;
+
+let
+ cfg = config.eth.programs.dwm;
+
+in {
+ options.eth.programs.dwm = {
+ enable = mkEnableOption "Whether to enable dwm";
+ };
+
+ config = mkIf cfg.enable {
+ environment.systemPackages = [ pkgs.eth.dwm ];
+ services.xserver.windowManager.session = singleton {
+ name = "dwm";
+ start = ''
+ ${pkgs.eth.dwm}/bin/dwm &
+ waitPID=$!
+ '';
+ };
+ };
+}