summaryrefslogtreecommitdiff
path: root/nixos/modules/services/helix-directory-jackalope.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-06-09 15:32:20 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-06-09 15:32:20 +0100
commit560988ea6f96ffb0ee534facba168abd8f999da3 (patch)
tree9aca56be1169aceb7164a4ac547b6af3c19590a7 /nixos/modules/services/helix-directory-jackalope.nix
parentaa8ad8747e4304c0d902e8b92feac4ecd8ded66d (diff)
add NixOS module eth.services.helix-directory-jackalope
Diffstat (limited to 'nixos/modules/services/helix-directory-jackalope.nix')
-rw-r--r--nixos/modules/services/helix-directory-jackalope.nix72
1 files changed, 72 insertions, 0 deletions
diff --git a/nixos/modules/services/helix-directory-jackalope.nix b/nixos/modules/services/helix-directory-jackalope.nix
new file mode 100644
index 0000000..fc1d95a
--- /dev/null
+++ b/nixos/modules/services/helix-directory-jackalope.nix
@@ -0,0 +1,72 @@
+{ config, lib, pkgs, ... }:
+with lib;
+
+let
+ cfg = config.eth.services.helix-directory-jackalope;
+
+in {
+
+ options.eth.services.helix-directory-jackalope = {
+
+ enable = mkEnableOption "Whether to enable helix-directory-jackalope";
+
+ friendlyName = mkOption {
+ type = types.str;
+ default = "Helix (${config.networking.hostName})";
+ description = "Human-readable name to broadcast";
+ example = "My Media Server";
+ };
+
+ directory = mkOption {
+ type = types.str;
+ default = "";
+ description = "Directory to serve";
+ example = "/mnt/md0/media";
+ };
+
+ jackalopePath = mkOption {
+ type = types.str;
+ default = "";
+ description = "Path to Jackalope DB";
+ example = "/mnt/md0/media/jackalope.db";
+ };
+ };
+
+
+ config = mkIf cfg.enable {
+ assertions = [
+ {
+ assertion = cfg.directory != "";
+ message = "must set config.eth.services.helix-directory-jackalope.directory";
+ }
+ {
+ assertion = cfg.jackalopePath != "";
+ message = "must set config.eth.services.helix-directory-jackalope.jackalopePath";
+ }
+ ];
+
+ systemd.services.helix-directory-jackalope = {
+ enable = true;
+ description = "Helix UPnP ContentDirectory server, with Jackalope";
+ wants = [ "network.target" ];
+ after = [ "network.target" ];
+ wantedBy = [ "multi-user.target" ];
+ path = [ pkgs.ffmpeg ];
+ serviceConfig = {
+ DynamicUser = true;
+
+ ExecStart = "${pkgs.eth.helix}/bin/helix-directory-jackalope -friendly-name ${escapeShellArg cfg.friendlyName} -path ${escapeShellArg cfg.directory} -jackalope-path ${escapeShellArg cfg.jackalopePath}";
+
+ Restart = "always";
+ RestartSec = "1min";
+
+ NoNewPrivileges = true;
+ ProtectHome = true;
+ ProtectKernelTunables = true;
+ ProtectControlGroups = true;
+ ProtectKernelModules = true;
+ };
+ };
+ };
+
+}