summaryrefslogtreecommitdiff
path: root/nixos/modules/yubikey.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
commit433a9ffcbddda74b0449eba251246a60221ae7cd (patch)
tree94792eabcb1e30b1f452ea18fd9c70e267aa4180 /nixos/modules/yubikey.nix
parent1d6f6c4c6f4823d1b969c6309ad2d472441b7b16 (diff)
better mirror upstream nixpkgs layout
Diffstat (limited to 'nixos/modules/yubikey.nix')
-rw-r--r--nixos/modules/yubikey.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/nixos/modules/yubikey.nix b/nixos/modules/yubikey.nix
new file mode 100644
index 0000000..0c16807
--- /dev/null
+++ b/nixos/modules/yubikey.nix
@@ -0,0 +1,47 @@
+{ config, lib, pkgs, ... }:
+with lib;
+
+let
+ cfg = config.eth.yubikey;
+
+in {
+
+ options.eth.yubikey = {
+ enable = mkEnableOption "Set up Yubikey";
+ };
+
+ config = mkIf cfg.enable {
+
+ hardware.u2f.enable = true;
+
+ programs.ssh.startAgent = false;
+
+ programs.gnupg.agent = {
+ enable = true;
+ enableSSHSupport = true;
+ pinentryFlavor = "curses";
+ };
+
+ services.pcscd.enable = true;
+
+ services.udev.packages = with pkgs; [
+ libu2f-host
+ yubikey-personalization
+ ];
+
+ environment.systemPackages = with pkgs; [
+ gnupg
+ pinentry-curses
+ ];
+
+ environment.shellInit = ''
+ gpg-connect-agent /bye
+ export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)
+ '';
+ programs.fish.shellInit = ''
+ gpg-connect-agent /bye
+ set -Ux SSH_AUTH_SOCK (gpgconf --list-dirs agent-ssh-socket)
+ '';
+
+ };
+}