summaryrefslogtreecommitdiff
path: root/modules/services/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/ssh.nix')
-rw-r--r--modules/services/ssh.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/services/ssh.nix b/modules/services/ssh.nix
deleted file mode 100644
index d965472..0000000
--- a/modules/services/ssh.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
- cfg = config.eth.services.ssh;
-
-in {
- options.eth.services.ssh = {
- enable = mkEnableOption "Whether to enable SSHd with Eth's defaults.";
-
- passwordAuthentication = mkOption {
- type = types.bool;
- default = false;
- description = "Whether to allow password authentication. Occasionally useful, used sparingly.";
- };
- };
-
- config = mkIf cfg.enable {
-
- security.pam.enableSSHAgentAuth = true;
- security.pam.services.sudo.sshAgentAuth = true;
-
- services.openssh = {
- enable = true;
- permitRootLogin = "no";
- passwordAuthentication = cfg.passwordAuthentication;
- };
- };
-}