summaryrefslogtreecommitdiff
path: root/nixos/modules/services/catbus-lgtv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/catbus-lgtv.nix')
-rw-r--r--nixos/modules/services/catbus-lgtv.nix17
1 files changed, 5 insertions, 12 deletions
diff --git a/nixos/modules/services/catbus-lgtv.nix b/nixos/modules/services/catbus-lgtv.nix
index 8011004..9b2af13 100644
--- a/nixos/modules/services/catbus-lgtv.nix
+++ b/nixos/modules/services/catbus-lgtv.nix
@@ -6,7 +6,7 @@ let
cfg = config.eth.services.catbus-lgtv;
configJSON = pkgs.writeText "config.json" (builtins.toJSON {
- mqttBroker = "tcp://${cfg.mqttBroker.host}:${toString cfg.mqttBroker.port}";
+ mqttBroker = cfg.mqttBroker;
apps = cfg.apps;
topics = {
app = cfg.topics.input;
@@ -23,17 +23,10 @@ in {
enable = mkEnableOption "Whether to enable the Catbus WebOS LGTV daemons.";
- mqttBroker = {
- host = mkOption {
- type = types.str;
- description = "Host of the MQTT broker.";
- example = "localhost";
- };
- port = mkOption {
- type = types.int;
- description = "Port of the MQTT broker.";
- default = 1883;
- };
+ mqttBroker = mkOption {
+ type = types.str;
+ description = "URL of the MQTT broker.";
+ example = "tcp://broker.local:1883";
};
tv = {