summaryrefslogtreecommitdiff
path: root/nixos/sites/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/sites/default.nix')
-rw-r--r--nixos/sites/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/nixos/sites/default.nix b/nixos/sites/default.nix
index b2b15e0..bd35924 100644
--- a/nixos/sites/default.nix
+++ b/nixos/sites/default.nix
@@ -1,6 +1,6 @@
{ pkgs, ... }:
-{
+rec {
catbus-web-ui = pkgs.callPackage ./catbus-web-ui.nix {};
cgit = pkgs.callPackage ./cgit.nix {};
go-packages = pkgs.callPackage ./go-packages.nix {};
@@ -37,9 +37,10 @@
proxySocket = socketPath: {
locations = {
- "/" = {
- proxyPass = "http://unix:/${socketPath}";
- };
+ "/" = proxyLocationSocket socketPath;
};
};
+ proxyLocationSocket = socketPath: {
+ proxyPass = "http://unix:${socketPath}";
+ };
}