summaryrefslogtreecommitdiff
path: root/modules/services/snapclient.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 21:45:44 +0100
commit433a9ffcbddda74b0449eba251246a60221ae7cd (patch)
tree94792eabcb1e30b1f452ea18fd9c70e267aa4180 /modules/services/snapclient.nix
parent1d6f6c4c6f4823d1b969c6309ad2d472441b7b16 (diff)
better mirror upstream nixpkgs layout
Diffstat (limited to 'modules/services/snapclient.nix')
-rw-r--r--modules/services/snapclient.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/modules/services/snapclient.nix b/modules/services/snapclient.nix
deleted file mode 100644
index 9f93131..0000000
--- a/modules/services/snapclient.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
-
- cfg = config.eth.services.snapclient;
-
-in {
-
- options.eth.services.snapclient = {
-
- enable = mkEnableOption "Whether to enable snapclient.";
-
- hostID = mkOption {
- type = types.str;
- default = config.networking.hostName;
- description = "The name to give to the snapserver.";
- example = "Living Room";
- };
- };
-
- config = mkIf cfg.enable {
-
- systemd.services.snapclient = {
- enable = true;
- description = "Snapcast client";
- wants = [ "network.target" "sound.target" ];
- after = [ "network.target" "sound.target" ];
- wantedBy = [ "multi-user.target" ];
- serviceConfig = {
- DynamicUser = "yes";
- Group = "audio";
- ExecStart = "${pkgs.snapcast}/bin/snapclient --hostID ${escapeShellArg cfg.hostID}";
- NoNewPrivileges = true;
- ProtectHome = true;
- ProtectKernelTunables = true;
- ProtectControlGroups = true;
- ProtectKernelModules = true;
- RestrictAddressFamilies = "AF_INET AF_INET6 AF_UNIX";
- RestrictNamespaces = true;
- };
- };
- };
-}