summaryrefslogtreecommitdiff
path: root/modules/services/snapclient.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/snapclient.nix')
-rw-r--r--modules/services/snapclient.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/modules/services/snapclient.nix b/modules/services/snapclient.nix
deleted file mode 100644
index 9f93131..0000000
--- a/modules/services/snapclient.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ config, lib, pkgs, ... }:
-with lib;
-
-let
-
- cfg = config.eth.services.snapclient;
-
-in {
-
- options.eth.services.snapclient = {
-
- enable = mkEnableOption "Whether to enable snapclient.";
-
- hostID = mkOption {
- type = types.str;
- default = config.networking.hostName;
- description = "The name to give to the snapserver.";
- example = "Living Room";
- };
- };
-
- config = mkIf cfg.enable {
-
- systemd.services.snapclient = {
- enable = true;
- description = "Snapcast client";
- wants = [ "network.target" "sound.target" ];
- after = [ "network.target" "sound.target" ];
- wantedBy = [ "multi-user.target" ];
- serviceConfig = {
- DynamicUser = "yes";
- Group = "audio";
- ExecStart = "${pkgs.snapcast}/bin/snapclient --hostID ${escapeShellArg cfg.hostID}";
- NoNewPrivileges = true;
- ProtectHome = true;
- ProtectKernelTunables = true;
- ProtectControlGroups = true;
- ProtectKernelModules = true;
- RestrictAddressFamilies = "AF_INET AF_INET6 AF_UNIX";
- RestrictNamespaces = true;
- };
- };
- };
-}