summaryrefslogtreecommitdiff
path: root/nixos/modules/hardware/keyboard.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-29 22:00:45 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-29 22:00:45 +0100
commit641c545bf27c15f8cd80d58122271d949b6b0727 (patch)
treea9d75cefe92e0e0f29b50c90899408c4e71cb391 /nixos/modules/hardware/keyboard.nix
parent5111fcc4a49bcef1c336e03f5279d053bae3806c (diff)
rename the keyboard config options
Diffstat (limited to 'nixos/modules/hardware/keyboard.nix')
-rw-r--r--nixos/modules/hardware/keyboard.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/hardware/keyboard.nix b/nixos/modules/hardware/keyboard.nix
index 69ab14a..dc68b2f 100644
--- a/nixos/modules/hardware/keyboard.nix
+++ b/nixos/modules/hardware/keyboard.nix
@@ -2,15 +2,15 @@
with lib;
let
- cfg = config.eth.keyboard;
+ cfg = config.eth.hardware.keyboard;
in {
- options.eth.keyboard = {
- enable = mkEnableOption "Eth's keyboard preferences";
+ options.eth.hardware.keyboard = {
+ enableColemak = mkEnableOption "Eth's keyboard preferences";
};
- config = mkIf cfg.enable {
+ config = mkIf cfg.enableColemak {
console.useXkbConfig = true;