summaryrefslogtreecommitdiff
path: root/nixos/modules/services/catbus-wakeonlan.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-06-29 23:18:00 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-06-29 23:18:00 +0100
commit8710105f65154d19f7c65be10dd95b0e4ccab63b (patch)
treeccce00feb646e4b28ac4045fd1e6ea59cf36b6a4 /nixos/modules/services/catbus-wakeonlan.nix
parentea0e976056ee1b1652a51dc1ae3b02debf80e74d (diff)
refactor eth.services.catbus-{networkpresence,wakeonlan}
Diffstat (limited to 'nixos/modules/services/catbus-wakeonlan.nix')
-rw-r--r--nixos/modules/services/catbus-wakeonlan.nix69
1 files changed, 69 insertions, 0 deletions
diff --git a/nixos/modules/services/catbus-wakeonlan.nix b/nixos/modules/services/catbus-wakeonlan.nix
new file mode 100644
index 0000000..0cf7edb
--- /dev/null
+++ b/nixos/modules/services/catbus-wakeonlan.nix
@@ -0,0 +1,69 @@
+{ config, lib, pkgs, ... }:
+with lib;
+
+let
+
+ cfg = config.eth.services.catbus-wakeonlan;
+
+ configJSON = pkgs.writeText "config.json" (builtins.toJSON {
+ mqttBroker = cfg.mqttBroker;
+ devices = cfg.devices;
+ });
+
+in {
+
+ options.eth.services.catbus-wakeonlan = {
+
+ enable = mkEnableOption "Whether to enable the Catbus Wake-On-LAN actuator";
+
+ mqttBroker = mkOption {
+ type = types.str;
+ description = "URL of the MQTT broker.";
+ example = "tcp://broker.local:1883";
+ };
+
+ devices = mkOption {
+ type = types.attrsOf (types.submodule {
+ options = {
+ mac = mkOption {
+ type = types.str;
+ description = "The device's MAC address";
+ example = "aa:bb:cc:dd:ee:ff";
+ };
+ topic = mkOption {
+ type = types.str;
+ description = "MQTT topic for controlling the device";
+ example = "home/house/speakers/power";
+ };
+ };
+ });
+ example = { TV = { mac = "aa:bb:cc:dd:ee:ff"; topic = "home/living-room/tv/power"; }; };
+ description = "A set of devices and their MACs & controller topics.";
+ };
+ };
+
+
+ config = mkIf cfg.enable {
+ systemd.services.catbus-wakeonlan-actuator = {
+ enable = true;
+ description = "Power devices on using Wake-On-LAN via Catbus";
+ wants = [ "network.target" ];
+ after = [ "network.target" ];
+ wantedBy = [ "multi-user.target" ];
+ serviceConfig = {
+ DynamicUser = true;
+
+ ExecStart = "${pkgs.eth.catbus-wakeonlan}/bin/catbus-actuator-wakeonlan --config-path ${configJSON}";
+
+ NoNewPrivileges = true;
+ ProtectKernelTunables = true;
+ ProtectControlGroups = true;
+ ProtectKernelModules = true;
+ RestrictAddressFamilies = "AF_INET AF_INET6";
+ RestrictNamespaces = true;
+ };
+ };
+ };
+
+}
+