summaryrefslogtreecommitdiff
path: root/nixos/modules/services/mosquitto.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-07-27 20:55:25 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-07-27 20:55:25 +0100
commit158cc7d9b1aae4629190358aed0df26e9b3198c2 (patch)
tree717fcd8d8f4c5185e994e3101e01cbab04d1bc1c /nixos/modules/services/mosquitto.nix
parent54e8b0380ddab30100779a193c968919af7095d2 (diff)
add extraConfig to eth.services.mosquitto
Diffstat (limited to 'nixos/modules/services/mosquitto.nix')
-rw-r--r--nixos/modules/services/mosquitto.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nixos/modules/services/mosquitto.nix b/nixos/modules/services/mosquitto.nix
index fecf8a4..0934014 100644
--- a/nixos/modules/services/mosquitto.nix
+++ b/nixos/modules/services/mosquitto.nix
@@ -23,6 +23,8 @@ let
persistence true
persistence_location ${stateDirectory}/
''}
+
+ ${cfg.extraConfig}
'';
in {
@@ -62,6 +64,13 @@ in {
};
};
+ extraConfig = mkOption {
+ type = types.str;
+ description = "Config to append to the generated config.";
+ example = ''
+ log_type all
+ '';
+ };
};
config = mkIf cfg.enable {