summaryrefslogtreecommitdiff
path: root/nixos/modules/services/mosquitto.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/mosquitto.nix')
-rw-r--r--nixos/modules/services/mosquitto.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nixos/modules/services/mosquitto.nix b/nixos/modules/services/mosquitto.nix
index fecf8a4..0934014 100644
--- a/nixos/modules/services/mosquitto.nix
+++ b/nixos/modules/services/mosquitto.nix
@@ -23,6 +23,8 @@ let
persistence true
persistence_location ${stateDirectory}/
''}
+
+ ${cfg.extraConfig}
'';
in {
@@ -62,6 +64,13 @@ in {
};
};
+ extraConfig = mkOption {
+ type = types.str;
+ description = "Config to append to the generated config.";
+ example = ''
+ log_type all
+ '';
+ };
};
config = mkIf cfg.enable {