summaryrefslogtreecommitdiff
path: root/pkgs/default.nix
diff options
context:
space:
mode:
authorEthel Morgan <eth@ethulhu.co.uk>2020-05-22 16:37:24 +0100
committerEthel Morgan <eth@ethulhu.co.uk>2020-05-22 16:37:24 +0100
commita0000bf3f1789555cdd1d8b586ff611ef9ad7e64 (patch)
tree8354d5d2890083e0766ba8139193fac601bc6544 /pkgs/default.nix
parent50b27be54d368f38945bae71bc0683330c2a7693 (diff)
create nixpkgs for upmpdcli and dependencies, also a NixOS module
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index f4b4a25..01810e2 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -1,5 +1,9 @@
-self: super: {
+pkgs: super: {
eth = {
- recipesEthMoe = self.callPackage ( builtins.fetchGit { url = "https://github.com/ethulhu/recipes.eth.moe"; } ) {};
+ recipesEthMoe = pkgs.callPackage ( builtins.fetchGit { url = "https://github.com/ethulhu/recipes.eth.moe"; } ) {};
+
+ libnpupnp = pkgs.callPackage ./libnpupnp { };
+ libupnpp = pkgs.callPackage ./libupnpp { };
+ upmpdcli = pkgs.callPackage ./upmpdcli { };
};
}